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 مقابل در را داوطلباني ها ييتوانا ،Symbian جازم سينو برنامه آزمون
ي حاوي آموزش دورهاين . سنجدميي ا هيپا اطلاعاتي آموزش برنامه

را در  ++C كاربرد هم و فهم هم كه باشدميي عمل وي تئور موضوعات
  .ديآزما يم Symbian عامل ستميسحوزه 

 همان سؤالات مخزن از كه استي سؤالات ازي ا مجموعه شامل آزمون هر
 فقط دهنده امتحان از و هستند دار وزن سؤالات. اند شده انتخاب دوره

 خواهد نشان امتحان مدت طول در كه شيها ييتوانا سطح در يسؤالات
 معتبر عنوان شوند، قبول امتحان در كهي افراد. شد خواهد دهيپرس داد،

  .كرد خواهند افتيدر را» Symbian مجاز سينو برنامه«ي صنعت

  :هاي ذيل مراجعه كنيدبه سايتبراي اطلاعات بيشتر، 
www.symbian.com/developer/academy و  

http://www.majinate.com  

   

  

Accredited Symbian Developer 
 مهارت كي ،)Symbian مجاز سينو برنامه(

 سانينو برنامهي  براي   صنعت  استاندارد

 .تاس هوشمندي ها يگوشي افزارها نرم
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Carbide.C++  1.3ويرايش  
  »استفاده از سيستم عامل سيمبين« سرياز 

  08/04، اولويرايش 

  :منتشر شده توسط
Symbian Software Limited 
2-6 Boundary Row 
Southwark 
London SE1 8HP 
UK 
www.symbian.com 

  تأليف، رفع مسئوليتم تجاري، حق ئعلا
 متعلق به شركت نرم افزاري Symbianبه ُ هاي وابستهو ديگر علامت Symbain ،Symbian OSكليه علاثم تجاري 

Symbian Software Ltd مي باشند .Symbian  علائم تجاري اشخاص ثالث را كه در اين مربوط به حقوق كليه

 كليه حقوق مادي و معنوي اين مستند متعلق به شركت 2008 ©. نمايدمي تصديقبه آنها اشاره شده است،  مستند

Symbian Software Ltd شركت صريح از طرف و نبايد بدون مجوز مكتوب مستندهيچ قسمتي از اين . مي باشد 

Symbian Software Ltd شركت .تكثير شود Symbian Software Ltd  هيچ ضمانتي مبني بر دقت و يا مناسب

است و به هيچ وجه نبايد  جهت ارائه اطلاعات كلي و عمومياطلاعات داخل اين سند فقط . دهدسند نمي بودن اطلاعات اين

  .براي هدف ديگري استفاده شوند

   

  :مؤلف

  اندرو مارك اسميت

 :ستارويرا

  اشلي گادوين
  :بازبيني

  جو استيكبوري
  نيل تيلور

  ديويد دورانت
  مايك تروژيلو

 :مشاور طراحي

  آنابل كوك
  سابينا آسلام

 

  :ترجمه به فارسي

  موسي مرادي

  :بازنگري ترجمه

  مصطفي هاديان دهكردي
  نژادسميرا عباس

  آزيتا اسماعيلي
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  مقدمه

 1.3ويرايش  ++Carbide Cافزار نرم بايي آشنا اطلاعات كلي جهت يحاو كتابچه نيا
1توسعه يكپارچه طيمح به عنوان يك

است  C++ Symbianهاي برنامهي برا ديجد 
نويسي و يا سايت برنامه) www.forum.nokia.com(توان از فروم نوكيا كه آن را مي

UIQ )developer.uiq.com (كرد دريافت.   

  Eclipse سكوي برنامه نويسي

Carbide C++  بر مبناي سكوي برنامه نويسيEclipse در اين سكو. است شده بنا 
 بازمتن پروژه كي عنوان به گر،يد شركت هفت و IBM شركت توسط 2001 سال نوامبر

ايجاد هاي مختلف، عامل ستميسي رو اجرا قابل و گانيرا IDE كي نساخت هدف با
شامل (عضوش  هايشركتو ) Eclipse )www.eclipse.orgتوسط بنياد  گرديد و

Symbian شودپشتيباني مي) و نوكيا .Eclipse  بازمتندر اين مدت به يك انجمن 
نويسي توسعهبرنامه سكويآن، بر تهيه يك  درهاي بنا شده تبديل شده است كه پروژه

 رو بهدر نتيجه تعداد . اندشده متمركز ،افزارساخت نرم جهت ٢چارچوب كاريپذير و 
بر هستند كه  يدر حال توليد محصولات تجاري و يا رايگان ها،شركتافزايشي از 

  .اشاره كرد ++Carbide C توان بهمي اند؛ به عنوان نمونهبنا شده Eclipseتكنولوژي 

. است مختلفي ابزارهاي كپارچگي جهت سهولت يطيمحايجاد  ،Eclipseي اصل هدف
 چارچوب هاي كاري شامل كهي معمار كي از ،Eclipse هدف، نيا به دنيرسي برا

 توانند ازابزارهاي مختلف مي .كنداستفاده ميت استفاده چندباره است، يبزرگ با قابل
هاي چارچوبحاوي  Eclipseاز جمله . مند شوندبهره هاي كاري چارچوباين  مزاياي
  :باشدمي ذيل كاري 

كاربري پايدار، چارچوب كاري براي مديريت و  واسطچارچوب كاري براي تهيه  
نويسي شده از طريق سيستم فايل، چارچوب كاري براي دسترسي بر اجزاي برنامه

                                                           
1
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نويسي گروهي، ، برنامه3زداييهاي اشكالسازها، نشستويرايشگرهاي متن، برنامه
هاي جديد با سكوي موجود به  سازي كدسهولت يكپارچه. و غيره ٤ويرايشكنترل 

. است Eclipseمعماري  هايويژگيمهمترين كاربردي، از  ٥عنوان واحدهاي افزونه
هاي مطرح IDEنيست، چون همه  Eclipseتنها مختص  افزونهالبته پشتيباني از كد 

در  اين است كه Eclipseكنند ولي ويژگي يكتاي ها را پشتيباني ميامروزي، افزونه
نويسهاي تهيه شده توسط برنامهبا چهارچوب كاري پايههاي بين چهارچوب كاري آن

  .امكانات، هيچ تفاوتي وجود ندارد توسعههاي مختلف به منظور 

  ++Carbide.c توسعه مجتمع طيمح

Carbide.c++ بر مبناي Eclipse  هاي  با داشتن افزونه كهبنا شده است  3.3ويرايش
هاي و همچنين ساخت پروژه ++Symbisn Cهاي كردن با فايلكار توانايي  مضاعف،

Symbian از آنجا كه . را دارا مي باشدCarbide.c++  بر پايهEclipse ،است 
سفارشي  بيشتر رايگان و يا تجاري ديگر، آن را هايافزونهبا نصب  نندتوامي كاربران

سازي ، سيستم مدليشويراسيستم كنترل توان به مي هاافزونه از جمله اين. كنند
UML  غيره اشاره كردو.  

سيستم روي  بر كنندهخودش داراي برنامه نصب زيراراحت است  ++Carbide.cنصب 
نويس با محيطي روبرو خواهد بعد از نصب و اجراي برنامه، برنامه. باشدميويندوز عامل 

. بينيداست؛ در شكل بعدي آن را مي Eclipseمانند محيط استاندارد هشد كه عيناً 
به برپايه آن آشنا هستند،  محصولاتو يا ديگر  Eclipseهايي كه با محيط نويسبرنامه

از  ++Carbide.c هايافزونهپي خواهند برد زيرا  ++Carbide.c سهولت استفاده از
  .كنندپيروي مي چارچوب كاري آنو  Eclipse اصول طراحي
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طراحي شده است، به  ++Symbian Cهاي براي كار با برنامه ++Carbide.cكه  از آنجا
دهد كه را نشان مي c/c++ project 6ي، نماIDE محيط فرض، سمت راستطور پيش

يك پروژه معمولي كه تشكيل دهنده  و منبع 7هاي كد، سرآيندبراي نمايش فايل
Symbian  ،طراحي شده استهستند.  

 Symbian project navigator، نماي اين نما دهد، زيرِنشان ميهمانطور كه تصوير بعد 
آدرس  MMPاي كه در فايل را همان گونه ++Symbian Cقرار دارد كه ساختار پروژه 

  .دهدتعريف شده است، نشان مي bld.infدر فايل و داده شده 

براي  CodeWorriorبه خوبي ها دستي اين گونه فايل نكه با ساخت يهاينويسبرنامه
  .فهم اين نما پي خواهند برد سهولتآشنايي دارند، به ، Symbianسيستم عامل 

برنامه نويس مي تواند  .وجود دارد ++Cو  C، يك ويرايشگر كد IDE مركز محيطدر 
با كليك كردن روي دكمه  چندين پنجره ويرايشگر را به صورت همزمان باز كند و 

و . بالاي پنجره مورد نظر و يا با زدن كليد ميانبر تعريف شده، به آن پنجره برود ٨زبانه
و  Outlineنماي : فرض، دو نما باز شده استبه طور پيش IDEبالاخره در سمت راست 

  .Helpنماي 
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هاي سرآيند استفاده شده و توابع تعريف شده در فايل كد فايل Outlineنماي  •
C++ دهدشگر را نشان ميانتخاب شده در ويراي. 

در  توسط نشانگر ماوس انتخاب شدهاطلاعات كمكي در مورد عنصر  Helpنماي  •
همچنين امكان خواندن هر موضوع كمكي مربوط . دهدنمايش ميرا  IDEمحيط 

  .كندهاي آن را فراهم ميو ويژگي ++Carbide.c به

 ++Symbian Cيك پروژه  ٩فراخوانيها كه به طور خودكار موقع مجموعه اين پنجره 
را  ++Carbide.c++ C/C 10يشوند، در محيط با يكديگر تركيب شده و دورنماظاهر مي
كليك در گوشه سمت راست قابل دهند كه اين دورنما به شكل يك آيكن شكل مي

حاوي  ++Carbide.cبينيد در شكل بعد اين آيكن را مي. شودبالاي محيط ديده مي
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. اندنويسي طراحي شدهست كه از قبل براي مراحل مختلف برنامهدورنماهاي مختلفي ا
موجود است كه مجموعه متفاوت ديگري از  debugبه عنوان مثال، يك دورنماي 

  .هاي اشكالزدايي استكند كه مناسب براي نشستها و نماها را در محيط باز ميپنجره

ها و نماهاي به دلخواه خود پنجرهتواند نويس ميالبته توجه داشته باشيد كه برنامه
هم موقع اجراي دوباره، اين  ++Carbide.cمربوط به يك دورنما را تغيير دهد و 

  .آوردتنظيمات را به ياد مي

 آرايش. تغيير داد Window > Open Perspectiveتوان توسط دورنماي فعلي را مي
 در حال حاضراهايي كه نم. شودذخيره شده و دورنماي جديد باز مي ،فعلي يدورنما

نماي مورد . باز كرد Window > Show Viewتوان توسط در معرض ديد نيستند را مي
نظر در موقعيت قبلي و يا در صورتي كه تاكنون در دورنماي فعلي باز نشده است، در 

  .شودفرض باز ميموقعيت پيش

   ++Symbian C موجودي هاپروژه 11كردن وارد

مختلفي را در  Symbianهاي ، از قبل پروژه++Symbian Cهاي نويسبعضي برنامه
و يا مجموعه ابزارهاي  CodeWarrior Symbianكامپيوترشان دارند كه با استفاده از 

 حاوي ابزار كمكي است كه ++Carbide.c. ساختندآنها را مي Symbianخط فرماني 
نكه نياز به ساخت يك پروژه بدون اي ها راتواند به سادگي اين پروژهمي برنامه نويس

پذير البته اين كار هم امكان(ها به آن باشد جديد و اضافه كردن دستي تمام فايل
به منظور وارد و صادر  ١٢هاجادوگرامكان ساخت  Eclipse .كند Carbideوارد ) است

با استفاده از اين  ++Carbide.c در. كندكردن اطلاعات از محيط را پشتيباني مي
همانطور كه تصوير هم نشان . تهيه شده است bld.infوارد كردن فايل  جادوگر امكان،
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كند كه اجرا مي importيك پنجره  File > Importنويس توسط منوي دهد، برنامهمي
 bld.infفايل  ناي براي وارد كردهاي مختلفي است؛ در اين ميان گزينهداراي انتخاب

بعد از انتخاب اين گزينه، از . داده شده است وجود دارد كه در تصوير اول زير نشان
وتر انتخاب كند كه در يرا از حافظه كاپ bld.infشود كه فايل نويس خواسته ميبرنامه

  .بينيدمي ذيلشكل دوم 

هاي نصب شده روي Symbian SDKتمام  ++Carbide.cبعد از اتمام اين گام،  
متناسب با پروژه  SDKنويس موظف است يك دهد و برنامهكامپيوتر ميزبان را نشان مي

تواند انتخاب نويس ميدر گام بعد، برنامه. بينيدرا انتخاب كند كه در تصوير بعد هم مي
، به منظور bld.infداده شده در فايل  ارجاع MMPهاي كند كه كدام يك از فايل

  .مناسب به كار رود MMP) هاي(كردن فايل ١٣تجزيه
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در پايان . تواند نام پروژه و دايركتوري ريشه را انتخاب كندنويس ميبرنامهدر نهايت، 
باز شده و آماده  ++Carbide.cدر  ++Symbian C، يك پروژه جادوگراجراي اين 

  .باشدنويسي ميبرنامه

  ديجد ++Symbian C پروژه كي جاديا

Carbide.c++  پروژه جديد را فراهم ميي است كه امكان ساخت يك جادوگرحاوي -

در تصاوير . اجرا كرد File > New Projectتوان از طريق منوي اين جادوگر را مي. كند
  :بينيدزير هم مي

  

 

 



١٣ 
 

  

Carbide.c++ در (هاي مختلف است هاي اختصاصي براي انواع پروژه14حاوي الگو
پروژه جديد  استفاده كردن از يكي از اين الگوها، يك .)صورت بالا نشان داده شده است

تعدادي فايل و مقداري كد  بسته به نوع پروژه انتخاب شده، ساخته و در همان لحظه،
  .هم توليد

هاي نصب شده روي كامپيوتر ميزبان SDKبه طور خوركار،  ++Carbide.cاز آنجايي كه 
هاي شناسايي شده، فيلتر SDKتوان براساس كند، الگوهاي پروژه را ميرا شناسايي مي

  .ردك

مرحله بعدي اين جادوگر، مسير ذخيره پروژه و سپس تنظيمات ساختي كه بايد فعال 
مرحله آخر جادوگر به . پرسد، كه در تصاوير بالا نشان داده شده استشوند را مي

گرچه اين مورد را بعداً هم (برنامه  UIDدهد كه اطلاعاتي مانند نويس اجازه ميبرنامه
هاي مختلف استفاده خواهند شد هايي كه براي ذخيره فايلپوشهو ) توان تغيير دادمي

شود و نتيجه آن، يك پس از اين مرحله، اجراي جادوگر كامل مي. را مشخص كند
  .توانند توسعه يابندپروژه جديد با تعدادي فايل اوليه خواهد بود كه بعداً مي
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  پروژهي هايژگيو

 Project Propertiesتوان با اجراي پنجره ژه را ميتعدادي از پارامترهاي مربوط به پرو
 C/C++ Projectsتوان با انتخاب پروژه مورد نظر در نماي اين پنجره را مي. تغيير داد

ماوس  كليك راستدر منويي كه با  Propertiesتوسط ماوس و سپس انتخاب منوي 
  .شود، اجرا كردآشكار مي

تواند نويس با استفاده از آنها ميكه برنامههاي مختلفي است اين پنجره حاوي قسمت
امكان تنظيم  Carbide Build Configurationبرگه . ساخت را كنترل كند 15پروسه
 Paths and Symbolsبرگه . دهدهاي مخصوص براي هدف ساخت پروژه را ميگزينه
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متغيرهاي محيطي مربوط  16سازيامكان تنظيم مسيرهاي مربوط به پروژه، سفارشي
و ساخت  PKGبا استفاده از فايل  SISپروسه ساخت، توليد خودكار فايل نصب شدني  به

- هايي كه گوشي، براي برنامهSymbian Signedمربوط به  Certificate/Keyدو فايل 

قسمت . فراهم مي آورد قرار داده اند،را هدف  x.9ويرايش  Symbianهاي داراي 
Carbide Project Settingsهاي فايل(ويس، امكان ساخت اجزاي پروژه ن، به برنامه

MMP( مبني بر فايل ،bld.inf دهدوارد شده را مي.  

Carbide.c++  فايل  تغييرامكانbld.inf هاي پروژه و فايلMMP  ك يمربوطه، توسط
 تغييرنويس امكان كه اين ويرايشگر به برنامهفراهم مي آورد،  نيز ويرايشگر گرافيكي را

ها آشنايي و پارامترهاي اين فايل 17ساختار نحو، بدون اينكه با  هاي پروژهويژگي
از نماي  MMPهاي توان با باز كردن فايلاين ويرايشگرها را مي. دهد، ميباشد

Symbian Project Navigator  ياC/C++ Project ويرايشگر . اجرا كردMMP  در تصوير
  :زير نشان داده شده است

  

تواند تمام اطلاعات لازم را توسط ويرايشگرهاي گرافيكي نويس ميبرنامهبنابراين 
در پايين پنجره  MMPيا فايل  bld.inf زبانهروش ديگر، كليك كردن روي  .تنظيم كند
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توجه داشته باشيد كه . ها به كمك ويرايشگر متني استو ويرايش دستي اين فايل
Carbide.c++ گي با تغييراتي كه كاربر در بيرون ها را در هماهنهميشه اين فايل

افزودن  توان بهميتغييرات بيروني از جمله . دارددهد، نگه ميويرايشگرها انجام مي
همچنين . اشاره كرد ++Carbide.cها كد به پروژه توسط رابط كاربري اصلي فايل

در ها، باعث به روز شدن خودكار اطلاعات نمايش داده شده ويرايش دستي اين فايل
  .شودويرايشگرهاي گرافيكي مي

  يسراسر ماتيتنظ

به كاربر امكان مشخص كردن  ++Carbide.cعلاوه بر تنظيمات مخصوص پروژه، 
را تحت تأثير قرار  C++ Symbianهاي تنظيمات سراسري كه رفتار محيط و همه پروژه

دسترسي  قابل Preferencesاين تنظيمات از پنجره . دهدخواهند داد را نيز مي
همان . آن را اجرا كردتوان مي Window > Preferencesاز طريق منوي  كههستند 

نويس برنامه طور كه در تصوير زير هم نشان داده شده است، در سمت چپ اين پنجره،
گروه تنظيماتي كه بايد تغيير داده شوند را انتخاب كند، مثلاً تنظيمات  مي تواند

در حالي كه در سمت راست، تنظيمات موجود  .غيرهعمومي، تنظيمات ويرايشگر و 
  .شوندبراي گروه انتخاب شده، ظاهر مي
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. قرار دارند ++Carbide.c، در درخت C++ Symbian ينويستنظيمات مخصوص برنامه
هاي نصب Symbian SDKنويس امكان مديريت ، به برنامهSDK Preferencesدرخت 

هايي براي ، حاوي انتخابBuildمورد . دهدهاي آنها را ميشده و تغيير ويژگي
ها، به عنوان مثال اين كه كد آزمايشي فرض پروژهسازي رفتار ساخت پيشسفارشي

  .ساخته شود يا نه، است

Carbide.c++ كليد عمول كه برعهده محيط هستند، ميانبرهاي صفحهبراي كارهاي م
، امكان تغيير اين General Preferencesدر داخل  Keysمورد . تعريف كرده است

توان يك مورد خاص را تغيير داد و يا اينكه در اينجا مي. فراهم مي آوردميانبرها را 
و يا  CodeWarriorهاي مثلاً طرح. از پيش تعريف شده را انتخاب كرد 18يك طرح

Visual Studio.    
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  كد شيرايو و شيمايپ

، صرف ديدن و تغيير IDEنويس موقع استفاده از يك مقدار قابل توجهي از زمان برنامه
داراي تعداد زيادي مشخصه مفيد براي ويرايشگر است، به  ++Carbide.c. شودكد مي

  :عنوان مثال

  جستجو
. كندها فراهم ميدر فايل را امكان جستجوي عبارات …Search > Searchمنوي 

هاي تعريف اي از فايلبه زيرمجموعه يا هاي با نوع خاص وتوان به فايلجستجو را مي
 Searchتوان در نماي نتايج را مي. محدود كرد شده توسط محيط كار، پروژه و يا پوشه

  .مشاهده كرد System Searchو يا 

  دميانبرهاي صفحه كلي
، داراي ميانبرهاي صفحه ++Carbide.cهاي ويرايشي و يا پيمايشي بسياري از مشخصه

هاي ميان فايل Alt-Rightو يا  Alt-Leftبه عنوان مثال، . كليد وابسته به خود هستند
كند متن انتخاب شده را كامنت مي /+Ctrlروند، باز شده در ويرايشگر، جلو و عقب مي

 Ctrl+Alt+Hكند و پروژه را كامپايل مي Ctrl+Alt+Cكند، ج ميو يا از حالت كامنت خار
ميانبرهاي . كندمراتب صدا زدن را براي مشخصه زير نشانگر ماوس باز مييك سلسله

  .مشاهده كرد Window > Preferencesتوان در موجود براي يك دورنما را مي

  20و صدا زدن 19مراتب نوعسلسله
اين . كندنشانگر ماوس است، باز مي براي كلاسي كه زيرٍمراتب نوع را ، سلسلهF4زدن 

همان طور . دهدمراتب وراثت و توابع تعريف شده در هر سطح را نشان ميكار، سلسله
مراتب صدا زدن را براي ، سلسلهCtrl+Alt+Hكه در بالا هم توضيح داده شد، زدن 

هاي داخل پروژه كه در آنها تابع كند و اين كار تمام مكاننشانگر باز مي مشخصه زيرٍ
ابي كمك مفيدي يبراي عيب كهكند شود را فهرست ميانتخاب شده صدا زده مي

  .است
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  الگوهاي كد
تعداد زياد . تغيير خواهد داد (”“)LIT_، آن را به Ctrl+Spaceو فشردن  litتايپ كردن 

 < ++Window > Preferences > C/Cديگري از اين الگوهاي كد موجود است كه در 

Editor > Templates اند، به عنوان مثال، الگوهاي استفاده شده براي فهرست شده
Cleanup Stack هاي و ساختارهاي كنترلي مثل حلقهfor  وwhile . امكان تعريف

  .ي جديد نيز در اينجا فراهم استهاالگو

  تاريخچه محلي
 Team > Show Local و انتخاب Project Explorerروي يك فايل در  كليك راست

Historyهاي قديمي فايل را كه پس از هر تغييري در فايل ذخيره ، فهرستي از ويرايش
توان ويرايش فعلي فايل را با موارد قبلي مقايسه از اين نما مي. دهداند، نمايش ميشده

  .كرد و در صورت نياز آن را برگرداند

  21وظايف
- را مي وظايف. كندنويسي فراهم ميبرنامه وظايفروشي براي مديريت  Tasksنماي 

را  TODOهاي حاوي كلمه اضافه كرد و يا اينكه كامنت Tasksتوان مستقيماً به نماي 
جديد به نماي  وظيفهبه كد اضافه كرد و متن كامنت به طور خودكار به عنوان يك 

Tasks يع براي ها، يك راه سرايجاد شده توسط كامنت وظايفاين . اضافه خواهد شد
  .كنندرا فراهم مي Tasksاز نماي  مربوطه دسترسي به كد

  هاي مختلف صفحهويرايش در قسمت
با درگ كردن برگه ويرايشگر يك فايل باز به قسمت ديگري از محيط، يك پنجره 

 تعداد تواند هرنويس ميبا تكرار اين عمل، برنامه. توان ايجاد كردويرايشگر ديگر را مي
گر لازم را باز كند تا بتواند در يك زمان، بيشتر از يك فايل كد و پنجره ويرايش

  .هاي مختلف يك فايل را ببيندهمچنين قسمت
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  برنامه كي ياجرا و ساخت

امكان باز كردن تعداد زيادي پروژه مختلف به صورت همزمان را  ++Carbide.cمحيط 
ا تعدادي پروژه يباز و  يهاامكان ساخت همه پروژه به كاربر، در نتيجه. فراهم مي آورد

  :به صورت زير است ++Carbide.cمراحل ساخت يك پروژه در . دهدانتخاب شده را مي
روي  C/C++ Projectدر نماي (اي كه بايد ساخته شود را انتخاب كنيد پروژه •

 )پروژه كليك كنيد

 Project > Active Buildرا با استفاده از منوي  مورد نظر فعال ساختنحوه  •

Configuration انتخاب كنيد. 

  .بسازيد Project > Build Projectپروژه را با انتخاب منوي  •

Carbide.c++  سازد و به انتخاب شما ، مي22كردن لينكپروژه را با كامپايل كردن و
- مياگر لازم باشد، . كندتوليد مي مورد نظر فعال ساخترا با توجه به نحوه  SISفايل 
اين كار . مناسب، توليد كرد PKGبا انتخاب فايل  در پايانِ ساخت، را SISفايل توان 
خطاها و اخطارها در . كندمي 23را توليد كرده و به دلخواه شما آن را امضا SISفايل 

تواند روي نويس ميشوند و برنامهنشان داده مي Problemsپايين محيط در نماي 
طا يا اخطار را توليد كرده است را ها كليك كرده و به طور خودكار متني كه خپيام

شود و آيكن كد توليد كننده خطا يا اخطار، در ويرايشگر زيرش خط كشيده مي. ببيند
، دستوراتي كه Consoleنماي . شودگذاري ميمناسب خطا و يا اخطار، علامت

Carbide.c++ هاي خطا و اخطاري كه كند را به همراه پيامبراي ساخت پروژه اجرا مي
  .دهد اند، نمايش ميسط كامپايلر، لينكر و يا ديگر ابزارهاي ساخت توليد شدهتو

توان پس از اينكه عمليات ساخت تكميل شد و تمام خطاها برطرف شدند، برنامه را مي
. ساخت، اجرا كرد نحوهبه  با توجهو يا گوشي موبايل،  Symbianساز در شبيه

Carbide.c++ كند و ا براي پروژه كامپايل شده ايجاد ميبه طور خودكار يك محيط اجر
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) Ctrl+F11و يا با زدن ( Run > Runتواند با انتخاب منوي نويس ميبنابراين برنامه
 Run > Debugتوان با انتخاب منوي زدايي را هم ميبرنامه را اجرا كند، محيط اشكال

غيير داد و همچنين توان تها را ميتنظيمات اين محيط. اجرا كرد) F11و يا با زدن (
 Run > Open Runو با انتخاب  Runجديد را به كمك منوي  ياجرا يهامحيط

Dialog… زدايي جديد را به كمك منوي اشكال يهاو يا محيطDebug 

Configuration با انتخاب   وRun > Open Debug Dialog…ايجاد كرد ،.  

نويس ، برنامهRun Configurationپنجره  دهد، درنشان مي همانطور كه تصوير زير
و يا گوشي موبايل  Symbianساز ي جديد كه هدفش شبيهيتواند يك محيط اجرامي

است را ايجاد كند و تنظيمات مختلف مثل دستورات خط فرمان براي برنامه، درگاه 
به گوشي براي  SISبه منظور ارسال فايل  ++Carbide.cبراي  USBارتباطي بلوتوث يا 

با . را مشخص كند غيرههاي كد و زدايي برنامه روي موبايل، مكان فايلو يا اشكالاجرا 
هاي خاص ساخت و در توان براي پروژها و هدفهاي مختلفي را مياين روش، محيط

    .استفاده كرد ++Carbide.cمتوالي  24هاينشست
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  25ييزدااشكالي هانشست

زدايي كه در هاي اشكالاز محيط توان از طريق يكيزدايي را ميهاي اشكالنشست
نويس اجازه زدايي به برنامهيك محيط اشكال. قسمت قبل توضيح داده شد، اجرا كرد

 26سازي كند، به عنوان مثال، استثناهاييزدايي برنامه را سفارشيدهد نحوه اشكالمي
ع بايد در تاب توقف برنامهبايد بگيرد و يا اينكه آيا يك نقطه  ++Carbide.cكه 

E32Main چه (هر زمان كه برنامه توسط ديباگر اجرا شود . برنامه قرار داده شود يا نه
 Debugبه دورنماي  ++Carbide.c، )و چه در گوشي موبايل Symbianساز در شبيه
از تمام  ++Carbide.c. كه در تصوير بعدي هم نشان داده شده است شودوارد مي

- شوند، پشتيباني ميهاي معمول ديگر يافت ميزدايي كه در محيطهاي اشكالويژگي

قابل ديد  Debugهاي تشكيل دهنده برنامه در حال اجرا، در نماي 27ريسه. كند
و يا پروسه را به منظور دريافت اطلاعات از ريسه توان يك نويس ميبرنامه. هستند

  .اش، در اين نما انتخاب كرده و آزمايش كندو يا متغيرهاي محليريسه  28پشته

 30و نقاط نظارت 29 توقف برنامهنويس امكان ساخت نقاط به برنامه Breakpointsبرگه 
و يا  انفراديبه صورت  بندي كرد و از آنتوان گروهمي را توقف برنامهنقاط . دهدرا مي

- اي كه براي آن ساخته شدهموجوديت در فايل يا پروژه گروهي، به عنوان مثال طبق

نقاط توان با قرار دادن ميساز، زدايي توسط شبيهاشكالموقع . كرد استفادهاند، 
زدايي ، اين كار براي اشكالمشخص نمودوضعيت يك متغير خاص را نشان  ،نظارت

هايي كه متغيرهاي تحت ريسه ، ++Carbide.cحافظه مفيد است، زيرا  اشكالات خرابيٍ
  .كنددهند را موقتاً غيرفعال مينظارت را تغيير مي
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آزمايش كرد كه  Variablesتوان در نماي مقادير متغيرهاي محلي و سراسري را مي
- است و مي 31هاگرتوصيف، مثل Symbianاين نما قادر به تفسير اطلاعات مخصوص 

توان به هاي حافظه را ميو آدرس ٣٢هاثباتمقادير . تواند مقادير آنها را نشان دهد
- از اين نماها مي. مشاهده كرد و تغيير داد Memoryو  Registersترتيب در نماهاي 

 .توان براي تحليل و تغيير وضعيت يك برنامه استفاده كرد

تواند داخل توابع شود و يا از روي آنها عبور كند، برنامه را تا نقطه در نهايت، كاربر مي
بعدي اجرا كند و بالاخره در حالي كه مشغول ديدن كد و خط جاري اجرا شده توقف 

  .زدايي را خاتمه داده و يا دوباره شروع كنديرايشگر است، نشست اشكالدر و
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  1.3 شيرايو ++Carbide.c در ديجدي هايژگيو

وجود دارد كه تاكنون توضيح داده  1.3ويرايش  ++Carbide.cتعدادي ويژگي جديد در 
  :آنها عبارتند از. اندنشده

ها سرعت ساخت پروژههاي ساخت سيستمي انتخابي كه باعث افزايش ويژگي •
 < ++Preferences > Carbide.cتوان از طريق ها ميبه اين گزينه. شوندمي

Build نويس، امكان هدايت اينها به برنامه. دسترسي داشتCarbide.c++  براي
هاي ساخت به طور و اجراي پروسه 33هاوابستگي مجزايمديريت ساخت 
 .دهنداي را ميهاي چندهستههمزمان در رايانه

در دسترس  …Search > Systemويژگي جستجوي سيستمي از طريق منوي  •
دهد و فقط محدود هاي دلخواه در رايانه را مياست كه امكان جستجو در پوشه

 .هاي محيط كار فعلي نيستبه فايل

كليك كردن روي فايل در نماي توان با راستهاي كد پروژه را ميفايل •
Symbian Project Navigator  و انتخابPreprocessپيش. پردازش كرد، پيش -

نمايش  Consoleروي تمام فايل اجرا شده و خروجي را در نماي  Cدازشگر رپ
 .خواهد داد

توان به موقع شروع يك محيط كار جديد، تنظيمات محيط كار فعلي را مي •
 Fileتوان از طريق انتخاب اين گزينه را مي. محيط كار جديد، كپي كرد

>Switch Workspace > Other…  و انتخاب مواردي كه بايد كپي شوند، اجرا
 .كرد

نياز  MMPكه يك فايل  34هاييتحليلي از قابليت Platform Securityنماي  •
 Runو انتخاب  MMPروي يك فايل  كليك راستبا . دهدخواهد داشت، ارائه مي
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Capability Scanner on Project MMPياز خواهد هايي كه برنامه ن، قابليت
 .به صورت خلاصه نشان داده خواهند شد Patform Securityداشت، در نماي 

در حال رشد است، تعداد در حال  ++Carbide.cهمانطور كه اكوسيستم  •
. نيز در دسترس است ++Carbide.cهاي براي گسترش قابليت افزونهافزايشي 

و يا  Symbianهستند و توسط  Symbianها مخصوص افزونهبعضي از اين 
Nokia تر بوده و مخصوص اند در حالي كه بقيه كليساخته شدهEclipse  هستند

، در آدرس زير در صفحه ويكي اين كتابچه. اندو توسط مراجع ديگر ساخته شده
 :هاي مفيد موجود استافزونهاطلاعاتي در مورد 

developer.symbian.com/carbide_booklet_wikipage 
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  ياري و اطلاعات

شامل چگونگي وارد  ++Carbide.cدر اين كتابچه ما مقداري اطلاعات اساسي در مورد 
اطلاعات . ارائه داديم C++ Symbianهاي زدايي و اجراي پروژهكردن، ساختن، اشكال

، از طريق IDEتوان از خود را مي ++Carbide.cهاي بيشتر در رابطه با تمام ويژگي
  .ه دست آوريدب Help > Help Contentsمنوي 

Help  همچنين برايEclipse هاي مخصوص و ويژگيCarbide.c++  بنا شده روي
Eclipse  و همچنين برايSymbian SDKمنبع مفيدي از . هاي نصب شده، موجود است

موجود است  ++Carbide.cاطلاعات در سايت فروم نوكيا براي 
)www.forum.nokia.com/carbide ( هاي ، برگهمقالات آموزشيكه حاوي

- هايي به فروشگاه الكترونيك فروم نوكيا كه ميپيوندو  36متداول، سؤالات 35اطلاعات

  .مي باشد، خريداري نمودرا  ++Carbide.cتوان از آنجا 

شده در شبكه  ارسالهاي هاي مختلف و مقالهديگر منابع مفيد اطلاعات، شامل فروم
 UIQت جامعه توسعه و ساي) Symbian )developer.symbian.comتوسعه 

)developer.uiq.com (كنديك صفحه ويكي هم اين كتابچه را همراهي مي. است:  

developer.symbian.com/carbide_booklet_wikipage 
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 Data sheets 
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 Frequently Asked Questions (FAQ) 
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  يسينو برنامه منابع

  Symbian توسعه شبكه
developer.symbian.com 

  Symbian توسعه شبكه خبرنامه
developer.symbian.com/register.action 

  هاSymbian SDK و ابزارها
developer.symbian.com/main/tools 

  اينوك فروم
forum.nokia.com 

 UIQنويسي برنامه جامعه

developer.uiq.com 
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  جديد ازهاي كتاب                                       

   

 

Games on Symbian OS: A Handbook for Mobile Development 

  

 از Technologyي سر از كتاب، نيا
 ،كتاب نيا. است Symbian انتشارات

 با را ليموباي ها يباز بازاري ديكلي ها جنبه
ي برا ها يباز ساخت بر قيدق تمركز

 Symbian هيپا بر هوشمندي ها يگوش
  .دهد يم شرح ،x.9 شيرايو

  

Developing Software for Symbian OS, Second Edition 

  

 Developing كتاب دوم شيرايو

Software for Symbian OS، به 
 كمك Symbian در كار تازه سانينو برنامه

ي ها يگوش مخصوصي ها برنامه تا كند يم
ي براي اصل كتاب. بسازند هوشمند

Symbian و است شده روز به 9 شيرايو 
 ثبت مورد در ديجد فصل كي يدارا الان

ي براي كل راتييتغ و تيامن و كردن
Symbian طيمح در راتييتغ و 9 شيرايو 

  .استي سينو برنامه
 developer.symbian.com/press:   انتشارات سيمبين
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  جديد ازهاي كتاب                                       

   

 

Symbian OS Communications Programming, Second Edition 

  

 Symbian OS Communications كتاب

Programming – Second Edition كه 
Symbian 9.1 است، گرفته هدف را 9.2 و 

 در ارتباطات ميعظ عملكرد با را شما
Symbian ي كارها انجام نحوه و كرده آشنا

  .دهد يم شرح را هيناح هر در معمول

  

Symbian OS C++ for Mobile Phones, Volume 3 

 كي تا كرد خواهد كمك شما به كتاب نيا
 شما به و ديشو Symbian مؤثر سينو برنامه

 بر Symbian كهي اساس اصول ازي قيعم فهم
  .دهد يم را است استوار آنها

  

 developer.symbian.com/press:   انتشارات سيمبين
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  از ديگري يهاكتاب                                       

  

    

The Symbian OS Architecture Sourcebook 

  

 مورد در عيسر شامل يك گذر كي كتاب نيا
 بايي آشنا كي كه است Symbianي معمار

 به افزار نرم در) OO(يي گرا يشي ها دهيا
  عامل ستميسي معمار قيدق كاوش همراه

Symbian كند يم فراهم را.  

  

S60 Programming 

 به كاملاً كه S60 Programming كتاب
 60ي سر و 9 شيرايو Symbianي برا روز

 توسعهي براي اساس هيپا كي است، 3 شيرايو
  .است Symbianي برا افزار نرم

 سندگانشينو اتيتجرب بر سودمند كتاب نيا
 دري دانشگاه درس سيتدر وي سينو برنامه در
 استوار Symbianي افزارها نرم توسعه نهيزم

  .است

 developer.symbian.com/press:   انتشارات سيمبين
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    هايي ديگر از كتاب                                       

 

  سيمبين ++Cنويسان  براي تمام برنامه

Symbian OS C++ for Mobile Phones - جلد اول  
  نوشته ريچارد هريسون

Symbian OS C++ for Mobile Phones - جلد دوم  
  نوشته ريچارد هريسون

Symbian OS Explained  
  نوشته جو استيكبوري

Symbian OS Internals  
  نوشته جين سيلس

        

Symbian OS Platform Security  
  نوشته كريگ هيت

Smartphone Operating Concepts With Symbian OS  
  نوشته مايك جيپينگ

Acredited Symbian Developer Primer  
  كوبسجينوشته جو استيكبوري و مارك 
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    هايي از كتابچه                                       

 

  هاي منتشر شده كتابچه

Coding Standards 

Coding Tips  
Performance Tips  

Getting Started  
Java ME on Symbian OS 

P.I.P.S  
Carbide.c++ 

Data Sharing Tips 

EssenIal S60 – Developers’ Guide 

Essential UIQ – Getting Started 

Ready for ROM 

  :ها موجود هستندهاي ترجمه شده در اين زبان كتابچه
  اسپانيايي  چيني
  روسي  ژاپني

  اي كره
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 چگونه؟ كجا؟ چه؟ ؟چرا

ي ها برنامهي برا توسعه مجتمع طيمح بري معرف كي كتابچه نيا
Symbian C++ ، ي عنيCarbide.c++ نيا. است 1.3 شيرايو 

 ++Cي ها پروژه كردن وارد نحوه د،يجدي ها يژگيو كتابچه،
Symbian ،ساخت نحوه و ديجد پروژه كي جاديا نحوه موجود 

  .ديگو يم شما به را ++Carbide.c توسط ها برنامهي اجرا و

Carbide.c++ عامل ستميس از استفاده«ي سر ازي بخش 
Symbian «ي برا اطلاعات هيته منظور به كه است

  .است شدهي طراح ،Symbian سانينو برنامه

  Symbian انتشارات

 ارتباط ايجاد منظور به كه كند يم منتشر رايي ها كتاب ،Symbian انتشارات
 وSymbian عامل ستميس دربارهي عمل اطلاعات و مرتبط موقع، به موثق،

ي اطلاعات ر،يز تيسا در ديتوان يم. اند شدهي طراح مربوطه،ي ها يتكنولوژ گريد
  :ديكن دايپ ،Symbian انتشاراتي سر درباره

developer.symbian.com/books 

 

 

 استفاده از سيستم عامل سيمبين

CARBIDE.C++ V1.3 

 


